Synology DS220+ "Mayday"

VON Dr. Wolf SiegertZUM Samstag Letzte Bearbeitung: 13. November 2020 um 13 Uhr 36 Minuten

 

Nach den vorangegangenen Berichten:
Synology DS220+ START
Synology DS220+ BETRIEB
Synology DS220+ FOLLOW-UP
war beabsichtigt, an diesem Tage zu beschreiben, wie ein auf der DS220plus funktionierenden System auf eine DS920plus portiert wird. Das wird letztendlich auch gelingen, aber der Weg dahin war mit ganz und gar unerwarteten "Irritationen" gepflastert...

Der für diesen Tag ausgearbeitete Vorbericht dazu "Synology DS220+ -> DS920+" musste auf eine Woche verschoben werden, da die bis spätestens heute erwartete Lieferung der neuen Festplatten nicht angekommen war.

Also sollten am Abend zuvor die Inhalt von zwei anderen nacheinander an "usbshare_2" angeschlossenen Seagate Platten in einen zuvor erstellte Ordner mit den Namen "Backup" auf dem NAS eingespielt werden.

Die Meldung zu Beginn des Tages sah aber bereits nach der ersten Platte so aus:

PNG

Das bedeutet, dass nur einer von drei Ordner "Daten", "Medien" "WS_only" umkopiert worden war. Die Inhalt von "Medien" und "WS_only" (bzw. "WS_privat") wurden nicht kopiert.

Was das genau bedeutet, geschweige denn, was der Grund für diesen Fehler war, geht aus dieser Meldung nicht hervor.

Also wurde ein neuer Ordner mit dem Namen "Backup_1" angelegt. Da dieser nicht auf der obersten Ebene eingerichtet werden konnte, wird die Funktion "Gemeinsamer Ordner anlegen" aufgerufen. Und dort ein solcher Ordner mit dem Namen "Backup_1" angelegt. Bei der Prüfung wurde gezeigt, dass dafür noch ca. 5 TB frei seien. Und nach den notwendigen Feineinstellungen...

PNG

...wird die Funktion über "Weiter" gestartet.

PNG

Das für den Nutzer danach sichtbare Ergebnis lautet: "Keine Daten"

PNG

Blanke Panik: das NAS wird sofort vom Netz getrennt.

Was ist passiert: Wie kann es sein, dass keine Daten mehr angezeigt werden, nur weil im Manager nicht ein neuer, sondern ein neuer gemeinsamer Ordner ("shared folder") angelegt wurde?

Wir bauen das NAS ab, ziehen nach und nach die Platten aus dem Schacht und unterwerfen diese einer besonderen Prüfung, die so aussieht:

~$ sudo mount /dev/vg1000/lv /mnt
mount: /mnt: wrong fs type, bad option, bad superblock on /dev/mapper/vg1000-lv, missing codepage or helper program, or other error.

Partitionsverzeichnis {PNG}

~$ sudo mdadm --assemble --readonly /dev/sdc1 /dev/sdb1
mdadm: device /dev/sdc1 exists but is not an md array.

Ist jetzt alles aus und vorbei???

Wir bauen die Festplatten wieder ein, starten das NAS neu, und sehen, dass nicht nur beide Volumes wieder angezeigt werden, sondern auch sowohl die bereits eingerichteten gemeinsamen Ordner zu finden sind, als auch der an diesem Tag neu angelegte.

Auch wenn die Ursache für diese "Fehl-"Anzeige noch nicht ausgemacht werden konnte, kommen wir zu der Entscheidung, diese Platten erneut aus der DS220+ auszubauen und in die 920+ zu verpflanzen.

Dazu genügte es im Grunde, dieser nachfolgend zitierten Anleitung zu folgen:

How to migrate between Synology NAS (DSM 6.0 and later)

Zunächst verhinderten die Sicherheitsfilter des Webbrowsers die Identifikation der IP-Adresse der neuen DS920+. Sie wurden deaktiviert, so dass schliesslich alle Javascripte geladen werden konnten.

Der nachfolgenden Ablauf ist in dieser Folge von Screenshots dokumentiert:

Zum Abschluss wurden wir mit einer Besonderheit des Telekom-Speedport-Routers 724 V konfrontiert. Dieses Gerät erlaubt keine Feinkonfiguration des DHCP-Servers. Die automatisch vergebene IP-Adresse der DS920+ musste deshalb stattdessen in der DS-Systemsteuerung fest eingestellt werden anstelle, wie von besseren Routern gewohnt, im DHCP fest einer MAC-Adresse zugeordnet zu werden.

Diese Information fand sich schliesslich in einem der Telekom-Supportforen. Dort heißt es:

"Feste IP Adressen können Sie bei diesem Router nur nutzen, wenn Sie die Adressen direkt in den entsprechenden Endgeräten konfigurieren. Über den DHCP Server des Routers lassen sich keine festen Adressen zuweisen."

Fazit:

- Wir loben die hohe Stabilität des Systems, die selbst dann erhalten bleibt, wenn man das Gerät mit einem shut-down stromlos macht.

- Wir bemängeln, dass bei bereits bei der Vorbereitung zum Erstellen von shared folders mittels der Systemsteuerung im File Manager minuten- bis stundenlang weder vorhandene öffentliche Ordner noch ihre Verzeichnisse oder Dateien angezeigt werden [1].

- Der Zugriff über das LAN mit SMB wird ebenfalls wesentlich verlangsamt. Wir vermuten jetzt als Ursache dafür die Verwendung von Festplatten mit einer Grösse von 10-Terabyte im RAID-Verbund.

Zum Ende der Folgewoche werden wohl die bestellten 10 TB Seagate IronWolfPro - Patten eingetroffen sein. Und dann werden wir testen, ob die hot-swap-Funktion auf der Basis einer Raid 1 - Konfiguration das wirklich tut, was das Konzept verspricht.

Anmerkungen

[1Für eingefleischte Admins, zumal mit einem Unix-Hintergrund, mag das normal sein, dass wegen Überlastung des Systems der Zugang zu allen Daten zeitweise abgeschaltet wird, aber für uns "Prosumer" offensichtlich dann doch nicht.


5164 Zeichen